home
 
 

Clarity SDK - HW & SW Requirements

Main Features

Installation and Requirements

Following conditions should be met for successful development of SDK control module:

  • Microsoft Windows 10, 8.1, 7SP1 or XPSP3.
  • Microsoft Visual Studio 2015 or 2010 with Unicode support (not Express edition, because SDK requires MFC).
  • Standard or your OEM version of Clarity station 4.0 or higher with HW key and corresponding Controls.
  • Optional: Clarity Training to become familiar with Clarity SW and terminology.
  • Optional: Clarity SDK Training to become familiar with SDK concept

SDK will install:

  • A DLL (and sources) for interfacing with Clarity.
  • Documentation and guidelines.
  • Several example control modules (DLL and sources).
  • A wizard for generating a basic structure of a new control module.

Deployment requirements

  • Clarity 4.0 and later
  • Microsoft Windows 10, 8.1, 7SP1 or XPSP3
 
Facebook Twitter Youtube  DataApex Clarity
Downloads
HTML navigation
Sitemap
Print
Last updated: 2017-08-10 | webmaster